[INC -841] US Region Data Center Issue

Incident Report for Imperva

Resolved

Service in the all us data center's have been restored to normal.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.

If any individual customers are continuing to experience a disruption in service, please continue to work with our Support team via https://supportportal.thalesgroup.com/
Posted May 14, 2025 - 18:22 UTC

Monitoring

Services across all our POP's are up now and we are monitoring the status.
Posted May 14, 2025 - 17:37 UTC

Update

All the POP's are up now and services has been restored to normal. We are investigating the root cause.
Posted May 14, 2025 - 17:21 UTC

Update

We are continuing to investigate the issue. It was a brief disruption and the services are getting back to normal across our POP's.
Posted May 14, 2025 - 17:12 UTC

Investigating

Technical teams are investigating a potential issue in the Data Centers in the US Region . Further updates to follow.
Posted May 14, 2025 - 16:44 UTC
This incident affected: North American PoPs (Ashburn, VA (IAD), Atlanta, GA (ATL), Chicago 1, IL (ORD), Chicago 2, IL (CHI), Dallas, TX (DFW), Denver, CO (DEN), Detroit, MI (DET), Houston, TX (HOU), Los Angeles, CA (LAX), Miami, FL (MIA), Montreal, Canada (YUL), New York 1, NY (NYC), New York 2, NY (EWR), San Jose, CA (SJC), Seattle, WA (SEA), Toronto, Canada (TOR), Vancouver, Canada (VAN)).