We have confirmed with the third-party CDN provider that they have begun to work on a configuration update which will correct the sub-optimal routing, with an ETA of up to 2 weeks before it is globally deployed. In the meantime, we continue to explore mitigation steps which we may be able to implement on a per-customer basis for impacted websites.
Posted Aug 13, 2026 - 20:16 UTC
Update
We are actively exploring potential mitigation options to address the sub-optimal routing and reduce the impact on affected origin fetch traffic. In parallel, we are working with the third-party provider to address the underlying geolocation issue. We will provide further updates as more information becomes available.
Posted Aug 13, 2026 - 17:55 UTC
Investigating
We have identified a condition where a subset of customer origin fetch traffic from our proxy servers in the WDC PoP is experiencing sub-optimal routing. In these cases, origin fetch is getting routed to specific third-party CDN networks in the APAC region instead of Eastern US, which is resulting in increased latency for origin fetch, and ultimately reduced performance in website access. While we are working with the third-party CDN on to correct their Geolocation routing information, we are exploring potential workarounds within our equipment to override the sub-optimal routing which is currently in place.
We will provide further updates as more information becomes available.
Posted Aug 13, 2026 - 16:53 UTC
This incident affects: North American PoPs (Ashburn 2, VA (WDC)).