The issue affecting user management has been resolved. Based on successful testing and continued stability, we have confirmed that the service is operating as expected, and the incident is considered resolved.
Posted Sep 11, 2026 - 01:50 UTC
Monitoring
The issue affecting user management and preventing new user invitations on the My Management platform has been resolved. The relevant teams have completed the required remediation, and user management functionality has been restored.
The platform is currently being monitored closely to confirm continued stability.
Posted Sep 10, 2026 - 22:03 UTC
Update
The issue affecting new user invitations remains under investigation, with the relevant teams continuing to work towards a resolution. Access for existing users to the My Management platform has been restored. The technical teams have completed the required remedial actions, and the platform is currently being monitored closely to confirm stability. We will provide further updates as more information becomes available.
Posted Sep 10, 2026 - 20:42 UTC
Update
The relevant teams continue to actively investigate the issue affecting new user invitations and are working towards implementing a resolution.
Separately, for the issue affecting some customers who experienced difficulties accessing or loading the My Management platform, our technical teams have identified the issue and implemented mitigation measures to restore service. Management Portal functionality is currently being validated, and we continue to monitor the environment closely to confirm stability.
We will provide further updates as more information becomes available.
Posted Sep 10, 2026 - 20:24 UTC
Identified
We have identified a potential cause for the issue preventing new user invitations on the My Management platform. The relevant teams are actively investigating and working towards implementing a resolution. Separately, the investigation into the issue affecting some customers who may experience difficulties accessing or loading the My Management platform continues. The relevant teams remain engaged in identifying the cause and restoring normal functionality. We will provide further updates as more information becomes available.
Posted Sep 10, 2026 - 19:05 UTC
Update
Our investigation into the issue preventing new user invitations on the My Management platform is continuing. The teams have identified a potential contributing factor related to the user management functionality and are continuing to investigate to confirm the root cause and determine the appropriate resolution. Separately, we continue to investigate the issue affecting some customers who may experience difficulties accessing or loading the My Management platform. The relevant teams remain actively engaged in identifying the cause and working towards restoring normal functionality. The next update on the issue will be provided no later than 19:05 UTC.
Posted Sep 10, 2026 - 18:30 UTC
Update
Our investigation into the issue preventing new user invitations on the My Management platform is continuing. The relevant teams remain engaged in identifying the root cause and working towards a resolution. Separately, we continue to investigate the issue affecting some customers who may experience difficulties accessing or loading the My Management platform. The relevant teams are actively working to identify the cause and restore normal functionality. Next update on the issue will be shared no later than 18:35 UTC
Posted Sep 10, 2026 - 18:04 UTC
Update
Our investigation into the issue preventing new user invitations on the My Management platform is ongoing. The relevant teams continue to work on identifying the root cause and implementing a resolution. Additionally, due to a separate issue, some customers may experience difficulties accessing or loading the My Management platform. Our teams are actively investigating this issue as well and working to identify the root cause. Next update on the issue will be shared no later than 18:00 UTC.
Posted Sep 10, 2026 - 17:29 UTC
Update
We are continuing to investigate an issue preventing new user invitations on the My Management platform. Additionally, due to a separate issue, some customers may experience difficulties accessing or loading the My Management platform. Our teams are actively investigating this issue as well and working to identify the root cause. Next update on the issue will be shared no later that 17:27 UTC.
Posted Sep 10, 2026 - 16:58 UTC
Update
We are continuing to investigate the issue preventing new user invitations on the My Management platform. Existing users can continue using the platform as normal. We will provide another update as more information becomes available.
Next update: no later than 16:30 UTC.
Posted Sep 10, 2026 - 16:11 UTC
Update
We are continuing to investigate the issue preventing new user invitations on the My Management platform. Existing users can continue using the platform as normal. We will provide another update as more information becomes available.
Next update: no later than 16:09 UTC.
Posted Sep 10, 2026 - 15:49 UTC
Update
We continue to actively investigate the issue affecting the ability to invite new users to the My Management platform. Our teams are reviewing the relevant systems and working to identify the root cause. Existing users can continue to access and use the platform as normal. We will provide another update as soon as more information becomes available.
Next update: no later than 15:44 UTC.
Posted Sep 10, 2026 - 15:25 UTC
Update
We continue to actively investigate the issue affecting the ability to invite new users to the My Management platform. Our teams are reviewing the relevant systems and working to identify the root cause. Existing users can continue to access and use the platform as normal. We will provide another update as soon as more information becomes available.
Next update: no later than 15:20 UTC.
Posted Sep 10, 2026 - 15:01 UTC
Update
We are continuing to actively investigate the issue affecting the ability to invite new users to the My Management platform. Our teams are reviewing the relevant systems to identify the root cause and determine the appropriate resolution. Existing users can continue to access and use the platform as normal. We will provide another update as soon as more information becomes available.
Next update: no later than 14:58 UTC.
Posted Sep 10, 2026 - 14:38 UTC
Update
We are continuing to actively investigate the issue affecting the ability to invite new users to the My Management platform. Our teams are reviewing the relevant systems to identify the root cause and determine the appropriate resolution. Existing users can continue to access and use the platform as normal. We will provide another update as soon as more information becomes available.
Next update: no later than 14:35 UTC.
Posted Sep 10, 2026 - 14:16 UTC
Update
We continue to actively investigate the issue affecting the ability to invite new users to the My Management platform. Our teams are reviewing the relevant systems and working to identify the root cause. Existing users can continue to access and use the platform as normal. We will provide another update as soon as more information becomes available.
Next update: no later than 14:15 UTC.
Posted Sep 10, 2026 - 13:54 UTC
Update
We continue to investigate an issue affecting the creation of new users in the Imperva Management Platform.
At this time, we are assessing whether the issue is intermittent rather than limited to a specific subset of customers. Our teams remain actively engaged in the investigation and are working to better understand the scope and underlying cause of the issue.
We apologise for the inconvenience and will provide further updates as soon as additional information becomes available.
Next update: no later than 13:55 UTC.
Posted Sep 10, 2026 - 13:34 UTC
Update
We are continuing to investigate an issue affecting the creation of new users in the Imperva Management Platform. The impact currently appears to be limited to a subset of customers.
Our teams are actively working to identify the cause and restore normal functionality. We apologise for the inconvenience and will provide further updates as soon as additional information becomes available.
Next update: no later than 13:35.
Posted Sep 10, 2026 - 13:13 UTC
Investigating
We are currently investigating an issue affecting the ability to invite new users to the Imperva Management platform. Existing users may continue to access and use the platform as normal. Our team is actively working to identify the cause and restore full functionality. We will provide further updates as more information becomes available. The next update will not be later than 13:15 UTC
Posted Sep 10, 2026 - 12:45 UTC
This incident affected: Management and Analytics Services (Account and User Management).