DNS Resolution Issue in the China region
Incident Report for Imperva
Resolved
The DNS resolution for Imperva's Cloud WAF has remained stable and functioning normally for the entire duration. The incident is being considered resolved.
Posted May 15, 2023 - 12:11 UTC
Monitoring
We have identified the impact to customer websites not being reachable in the China region. Imperva Cloud WAF Network is fully operational.
In order to mitigate the impact, please contact your DNS provider to ensure DNSSEC validation is in place.
Posted May 15, 2023 - 11:38 UTC
Identified
We have identified the source of customer websites not being reachable in the China region. We are working on remedial actions to mitigate the impact to customers at this time. Further updates will be provided as information becomes available.
Posted May 15, 2023 - 11:07 UTC
Investigating
We have discovered a potential service degradation in the China region. Some customer sites may not be reachable due to an issue with DNS Resolution. Technical teams are investigating.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted May 15, 2023 - 09:51 UTC
This incident affected: Services (Cloud WAF Network).