Monitoring has shown stable performance following the mitigation measures implemented earlier. This incident is considered resolved at this time. We will continue to monitor the environment as part of our standard operational practices to ensure ongoing service stability.
Posted Sep 03, 2026 - 00:33 UTC
Monitoring
We have rerouted traffic away from the affected carrier in the impacted PoPs, mitigating customer impact. We will continue to closely monitor the environment to ensure ongoing service stability.
Posted Sep 02, 2026 - 20:46 UTC
Investigating
Imperva has been alerted to the fact that there have been two major fiber cuts in North America. These fiber cuts are within the network of a major upstream carrier. A subset of customer traffic coming to or going from the Imperva network may transit this infrastructure and as a result of this issue, customers may experience connectivity issues, increased latency, or service degradation.
We will provide further updates as more information becomes available.
The next update will be before 20:50 UTC
Posted Sep 02, 2026 - 20:21 UTC
This incident affected: North American PoPs (Chicago 2, IL (CHI), Detroit, MI (DET), Houston, TX (HOU), Los Angeles, CA (SNA), Miami, FL (FLL), Montreal, Canada (YUL), New York 2, NY (EWR)).