[INC-994] Issue with Imperva Managed Certificates

Incident Report for Imperva

Resolved

The issue affecting certificate issuance has been resolved, and certificate ordering and issuance functionality have been fully restored.
Posted Mar 15, 2026 - 16:28 UTC

Monitoring

We are observing signs of recovery, and certificate issuance is beginning to function again. Our teams are currently validating system stability and monitoring the process closely.
Posted Mar 15, 2026 - 15:38 UTC

Update

We are continuing to work with our certificate authority provider to restore certificate issuance functionality. Existing certificates and active services remain unaffected.

Further updates will be shared as more information becomes available.
Posted Mar 15, 2026 - 13:08 UTC

Update

We are continuing to work closely with our certificate authority provider to resolve the issue affecting certificate issuance. Efforts are ongoing to restore normal functionality as quickly as possible.
We will provide further updates as additional information becomes available.
Posted Mar 15, 2026 - 10:14 UTC

Update

We are continuing to work with our certificate authority provider to resolve the issue affecting the ability to order or issue new certificates. Remediation efforts are currently in progress.
Existing certificates and active services remain unaffected. Further updates will be provided as more information becomes available.
Posted Mar 15, 2026 - 08:05 UTC

Identified

Our engineering team is actively working with the third-party certificate authority provider to resolve the issue affecting the issuance of new certificates.
We will continue to provide updates as progress is made toward restoring normal certificate ordering and issuance functionality.
Posted Mar 15, 2026 - 06:22 UTC

Investigating

We are currently experiencing an issue with the certificate issuance process with our upstream certificate authority provider. As a result, ordering or issuing new certificates is temporarily unavailable at this time.
This issue impacts all certificates managed through Imperva that require new issuance. Existing certificates and active services remain unaffected.
Our engineering team is actively working with the relevant provider to investigate and resolve the issue as quickly as possible. Further updates will be shared as more information becomes available.
Posted Mar 15, 2026 - 05:37 UTC
This incident affected: Third Party Services (Third Party Services).