[INC-779] SIEM Logs Issue Detected

Incident Report for Imperva

Resolved

SIEM logs have remained stable and no data has been lost during this event. At this time this incident is being considered resolved. We apologize for any inconvenience this issue may have caused.
Posted Feb 27, 2025 - 21:06 UTC

Monitoring

Technical teams have performed remedial actions and SIEM logs are returning to normal operations.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Feb 27, 2025 - 20:55 UTC

Identified

We have identified the source of the issue affecting SIEM logs which may result in 404 responses. No data was lost and technical teams are planning remedial action. Further updates to follow.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Feb 27, 2025 - 20:28 UTC

Investigating

We have discovered a potential issue affecting SIEM logs for a subset of customers using the Imperva API script. Technical teams are investigating. Further updates to follow.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Feb 27, 2025 - 19:07 UTC
This incident affected: Services (Weblogs).