[INC-829] Imperva Management Portal DNS Protection Zone Page Issue

Incident Report for Imperva

Resolved

The issue has been resolved and services has been restored to normal.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted May 05, 2025 - 09:46 UTC

Monitoring

A fix has been implemented and we are continuing to monitor in order to ensure that service has returned to normal.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted May 05, 2025 - 09:06 UTC

Investigating

We have discovered a potential service degradation, affecting the Imperva Management Portal. The DNS Zone page on the Management Portal is displaying errors and/or not responding. Customer sites are still fully protected by DNS Protection at this time. Technical teams are investigating. Further updates to follow.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted May 05, 2025 - 08:12 UTC
This incident affected: Services (Imperva Management Portal UI).