Our engineering teams have completed the remediation. The issue affecting cache purge functionality has been resolved.
The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.
In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Mar 05, 2026 - 22:59 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 05, 2026 - 22:11 UTC
Update
Our engineering teams have made progress in addressing the issue affecting cache purge functionality, and remediation efforts are ongoing.
Posted Mar 05, 2026 - 19:52 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 05, 2026 - 18:48 UTC
Identified
We have identified the issue affecting cache purge functionality. Our engineering teams are currently working on implementing a fix and restoring normal functionality. We will provide further updates as progress is made.
Posted Mar 05, 2026 - 17:57 UTC
Investigating
We are currently investigating a potential issue where cache purge requests may not be working as expected. As a result, some customer websites may temporarily display outdated or cached content. Our engineering teams are actively investigating the issue and working towards resolution. Further updates will be shared as more information becomes available.
Posted Mar 05, 2026 - 17:19 UTC
This incident affected: Protection Services - new category (starting Feb 22,2026) (Web Application Performance).