We have identified the source of the issue affecting the YUL (Montreal, Canada) PoP and are working on remediation. While completing the remediation may take an extended period of time, service has been stabilised by rerouting traffic through alternate Points of Presence (PoPs).
Traffic continues to be served through alternate locations, and we are not currently observing customer impact. We will continue to work towards restoring the YUL PoP to normal operation and will provide further updates as more information becomes available
Posted Aug 13, 2026 - 09:29 UTC
Update
Traffic is now being served by other PoPs, and service has stabilised. Our teams continue to investigate the underlying cause of the issue affecting the YUL infrastructure and are working towards restoring the PoP to normal operation.
We will continue to monitor the environment closely and provide further updates as they become available. The next update will be no later than 09:18 UTC.
Posted Aug 13, 2026 - 08:48 UTC
Monitoring
We have mitigated the issue affecting the YUL (Montreal, Canada) PoP by removing the affected PoP from service and redirecting traffic to alternate locations.
Traffic is now being served by other PoPs, and service has stabilised. Our teams continue to investigate the underlying cause of the issue affecting the YUL infrastructure and are working towards restoring the PoP to normal operation.
We will continue to monitor the environment closely and provide further updates as they become available. The next update will be no later than 09:05 UTC.
Posted Aug 13, 2026 - 08:34 UTC
Investigating
We are investigating an issue affecting traffic reaching our YUL (Montreal, Canada) PoP. Customers may experience connectivity issues, increased latency, or service disruptions when traffic is routed through this location.
Our teams are actively investigating the issue and working to identify the root cause. We will provide further updates as more information becomes available.
The next update will be before 08:51 UTC
Posted Aug 13, 2026 - 08:22 UTC
This incident affects: North American PoPs (Montreal, Canada (YUL)).