Completed
The scheduled maintenance has been completed.
Posted Feb 23, 2026 - 12:30 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 23, 2026 - 12:00 UTC
Scheduled
We are updating the Imperva Status page to improve clarity and consistency across services. As part of this update, existing services are renamed and reorganized, and some current service entries begin the deprecation process.
What’s changing on February 22, 2026:
The Status page uses an updated list of services, with revised naming and clear descriptions.
The single Services category is replaced with three categories:
o Protection services
o Management and analytics services
o Additional services
Existing services are marked as “Will be deprecated on March 22, 2026.”
What’s changing on March 22, 2026:
Services marked as deprecated are fully removed from the Status page.
What you need to do:
To continue receiving Status page updates for the relevant services, update your subscriptions to the new services before March 22, 2026.
1. Go to https://status.imperva.com/.
2. Click Subscribe to Updates.
3. Choose your preferred delivery method for notifications.
4. Under Components, select the new services you want to subscribe to.
If you do not subscribe to the new services, you will stop receiving updates when the deprecated services are removed.
Posted Feb 23, 2026 - 11:31 UTC
This scheduled maintenance affected: Services - this category will be deprecated on March 22, 2026 (Imperva Management Portal UI - (service will be deprecated on March 22, 2026), Imperva Management Portal API - (service will be deprecated on March 22, 2026), Imperva Management Portal- Configuration Changes - (service will be deprecated on March 22, 2026), Cloud WAF Network - (service will be deprecated on March 22, 2026), IP Protection - (service will be deprecated on March 22, 2026), Advanced Bot Protection - (service will be deprecated on March 22, 2026), Account Take Over - (service will be deprecated on March 22, 2026), DNS Protection - (service will be deprecated on March 22, 2026), JSONAR - (service will be deprecated on March 22, 2026), Client-Side Protection - (service will be deprecated on March 22, 2026), Cloud WAF GDPR - (service will be deprecated on March 22, 2026), Cloud WAF SIEM - (service will be deprecated on March 22, 2026), Cloud WAF Events & Statistics - (service will be deprecated on March 22, 2026), Attack Analytics - (service will be deprecated on March 22, 2026), Cloud Data Security - (service will be deprecated on March 22, 2026), Runtime Application Self Protection - (service will be deprecated on March 22, 2026), API Security - (service will be deprecated on March 22, 2026), Imperva Support - Ticketing and Phone Systems, Weblogs - (service will be deprecated on March 22, 2026), Network DDoS - (service will be deprecated on March 22, 2026)).