Support Phone outage

Incident Report for Imperva

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 09:59 UTC

Investigating

We are currently experiencing a Phone outage that is causing all callers to hear only silence when dialing any of our phone numbers. As a result, our support team is unable to receive incoming calls until this issue is resolved.

Our provider has confirmed that this is a widespread issue affecting multiple customers. Their team is actively working on a resolution, but no ETA is available at this time.

We will provide updates as soon as we have more information. In the meantime, please reach out to us via our customer portal.
Posted Mar 24, 2025 - 08:37 UTC
This incident affected: Services (Imperva Support - Ticketing and Phone Systems).