The issue affecting connectivity through the QRO PoP has been resolved. Following confirmation of stable network conditions, traffic has been restored to the QRO PoP and the bypass has been removed. We have continued to monitor service following the restoration and are no longer observing any impact.
This incident is now resolved. We thank you for your patience while we worked to restore normal operations.
Posted Aug 20, 2026 - 11:16 UTC
Update
Traffic has been restored to the affected QRO PoP and the bypass has been removed. Upstream providers continue to monitor the previously reported network issue, and service remains stable and operational at this time. We are closely monitoring performance and connectivity to ensure continued stability and will provide further updates if necessary.
Posted Aug 20, 2026 - 10:37 UTC
Monitoring
Traffic has been restored to the affected QRO PoP and the bypass has been removed. Upstream providers continue to monitor the previously reported network issue, and service remains stable and operational at this time. We are closely monitoring performance and connectivity to ensure continued stability and will provide further updates if necessary.
Posted Aug 20, 2026 - 10:07 UTC
Update
One of our upstream providers has now restored service, and connectivity through that provider is back online. Work is currently in progress with the remaining upstream provider to restore full connectivity.
The QRO PoP remains bypassed as restoration activities continue. We will provide further updates as more information becomes available
Posted Aug 20, 2026 - 06:55 UTC
Update
One of our upstream providers has now restored service, and connectivity through that provider is back online. Work is currently in progress with the remaining upstream provider to restore full connectivity.
The QRO PoP remains bypassed as restoration activities continue. We will provide further updates as more information becomes available.
Posted Aug 20, 2026 - 06:37 UTC
Update
The Queretaro, Mexico (QRO) PoP remains bypassed while our upstream providers continue working on service restoration. We will provide the next update as more information becomes available.
Posted Aug 20, 2026 - 04:39 UTC
Update
We continue to work closely with our upstream providers, who have acknowledged the issue and are actively working to restore normal service. To maintain service continuity, the affected PoP will remain bypassed while the providers work on restoration. Customers may experience increased latency during this period. We will provide further updates as more information becomes available.
Posted Aug 20, 2026 - 00:38 UTC
Identified
We are experiencing issues with upstream providers in the region. To minimize customer impact, the affected PoP has been bypassed and traffic is being rerouted through an alternate data center. Customers may experience some increased latency while the reroute is in place. Our teams are actively monitoring the situation and working with the upstream providers. We will provide the next update as more information becomes available.
Posted Aug 19, 2026 - 22:40 UTC
Investigating
We have identified an issue in the Queretaro, Mexico (QRO) data center. Traffic is being rerouted through an alternate data center in the region. Customers may encounter some latency for the duration of time that the reroute is in place.
Next update on the incident will be shared no later than 22:45 UTC
Posted Aug 19, 2026 - 22:17 UTC
This incident affected: LATAM PoPs (Queretaro, Mexico (QRO)).