[INC-1142] Network Connectivity Degradation Across Multiple PoPs Due to an Upstream Provider Issue

Incident Report for Imperva

Update

To maintain service stability, the impacted upstream provider remains bypassed. Our teams continue to closely monitor the environment and are working with the upstream provider to gather further information. Additional updates will be provided as more details become available.
Posted Sep 22, 2026 - 14:45 UTC

Monitoring

We have rerouted traffic away from the affected carrier in the impacted PoPs, mitigating customer impact. We will continue to closely monitor the environment to ensure ongoing service stability.
Posted Sep 22, 2026 - 11:38 UTC

Investigating

One of our upstream providers is currently experiencing a major outage.
We are contacting the provider to gather more information about the issue. As a mitigation, we have rerouted traffic away from the affected carrier at the impacted PoPs, which has mitigated customer impact.
We will continue to closely monitor the environment to ensure ongoing service stability. Further updates will be provided as more information becomes available.
Posted Sep 22, 2026 - 11:29 UTC
This incident affects: North American PoPs (Chicago 2, IL (CHI), Detroit, MI (DET), Houston, TX (HOU), Los Angeles, CA (SNA), Miami, FL (FLL), Montreal, Canada (YUL), New York 2, NY (EWR), Seattle, WA (SEA), Toronto, Canada (TOR), Vancouver, Canada (VAN)).