Service in the data center has been restored to normal.
Posted May 29, 2026 - 12:01 UTC
Monitoring
A fix has been implemented and traffic has been restored to the data center. We are continuing to monitor in order to ensure that service has returned to normal. The next update will be provided no later than 12:00 UTC.
Posted May 29, 2026 - 10:57 UTC
Identified
The issue has been identified, and technical teams are actively working on remediation. Customer traffic continues to be served normally through an alternate PoP. The next update will be provided no later than 10:46 UTC.
Posted May 29, 2026 - 10:16 UTC
Update
Investigation is ongoing. Technical teams continue to analyze the issue and validate findings. Customer traffic continues to be served normally through an alternate PoP. Next update will be shared no later then 10:18 UTC.
Posted May 29, 2026 - 09:48 UTC
Update
The investigation is ongoing, and technical teams continue to actively troubleshoot and analyze the issue to determine the underlying cause. Next update will be shared no later then 09:42 UTC.
Posted May 29, 2026 - 09:12 UTC
Investigating
During monitoring, the team identified some abnormalities in the network. The engineering team is currently re-investigating the issue, and traffic is being re-routed to an alternate data center.
Next update will be shared no later then 09:11 UTC.
Posted May 29, 2026 - 08:41 UTC
Monitoring
A fix has been implemented, and customer traffic continues to be served normally through the New York 2, NY (EWR) PoP.
We will continue to monitor the situation to ensure that service remains normal.
The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.
In the event of a service disruption, the update will include potential impacts to any affected region.
Posted May 29, 2026 - 07:25 UTC
Update
The technical teams have identified an issue affecting the New York 2, NY (EWR) data center. As a precautionary measure, the PoP will remain bypassed to ensure service stability and is planned to be reactivated during off-peak hours. Customer traffic continues to be served normally through an alternate PoP.
Engineering teams remain engaged in the investigation, and further updates will be shared as new information becomes available or once the PoP has been restored to normal operation.
Posted May 28, 2026 - 21:54 UTC
Update
As a precautionary measure, the New York 2, NY (EWR) data center will remain bypassed. Customer traffic continues to be served normally through an alternate PoP, and no customer action is required at this time.
Engineering teams will continue investigating the issue, and additional updates will be provided as changes occur or once the PoP is restored to normal operation.
Posted May 28, 2026 - 20:17 UTC
Update
Our Network Engineers continue to work on resolving the connectivity issues affecting the New York 2, NY (EWR) data center.
The next update will be provided no later than 20:00 UTC.
Posted May 28, 2026 - 19:30 UTC
Update
We have identified intermittent connectivity issues affecting the New York 2, NY (EWR) data center. Our Network Engineering team is actively working on remediation efforts. In the meantime, network traffic has been redirected to an alternate regional data center.
The next update will be provided no later than 19:27 UTC.
Posted May 28, 2026 - 18:57 UTC
Update
We have identified connectivity issues affecting our New York 2, NY (EWR) data center. Traffic is currently being re-routed to an alternate data center to minimize customer impact.
The next update will be provided no later than 18:53 UTC.
Posted May 28, 2026 - 18:23 UTC
Identified
We have identified connectivity issues in our New York 2, NY (EWR). traffic is being re-routed to an alternate data-center.
Next update will be shared no later then 18:37.
Posted May 28, 2026 - 18:09 UTC
This incident affected: North American PoPs (New York 2, NY (EWR)).