The issue that prevented some customers from logging in to the Customer Support Portal has been fully resolved. Technical teams implemented corrective actions and validated that normal login functionality has been restored. The Customer Support Portal is operating normally, and no further customer impact has been observed. We apologise for the inconvenience and appreciate your patience while we worked to resolve this issue. The incident is now closed.
Posted Jul 27, 2026 - 08:32 UTC
Monitoring
The issue preventing some customers from logging in to the Customer Support Portal has been resolved. Technical teams have completed remedial actions, and the portal has returned to normal operation. We are continuing to monitor the service to ensure stability and will provide a final update once monitoring is complete.
Posted Jul 27, 2026 - 07:45 UTC
Update
Our teams are actively working to restore access to the Support Ticketing System. While this work is ongoing, customers experiencing issues accessing the Support Portal can reach our Support team for urgent assistance by calling +1 410 469 1651. Thank you for your patience as we work to resolve the issue.
Posted Jul 27, 2026 - 06:49 UTC
Investigating
We are investigating a potential issue affecting the Support Ticketing System. Customers may be experiencing issues logging into the Support Portal. Our technical teams are actively investigating the issue.
The next update on the issue will be shared no later than 6:39 UTC.
Posted Jul 27, 2026 - 06:09 UTC
This incident affected: Additional services (Support Ticketing System).