[INC-1076] Querétaro, MX (QRO) Data Center Issue

Incident Report for Imperva

Resolved

The technical team implemented the necessary fixes, completed validation activities, and confirmed service stability through continuous monitoring. All services are operating normally. The PoP is fully operational and ready for service.

We appreciate your patience and understanding throughout this incident.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Jul 02, 2026 - 08:18 UTC

Monitoring

Technical team has successfully activated the PoP, and traffic has been restored to the Querétaro, MX (QRO) data center. Verification testing and continuous monitoring are currently underway to validate stability and confirm the PoP is fully operational and ready for service.

The next Status Update on this Incident will be provided no later than 8:13 UTC.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Jul 02, 2026 - 07:15 UTC

Update

The technical teams have identified an issue impacting the Querétaro, Mexico (QRO) data center. To maintain service stability, the PoP will remain in bypass mode as a precaution and is scheduled to be restored during off-peak hours. Customer traffic continues to be served without interruption through an alternate PoP.

Engineering teams are actively investigating the issue and working toward a resolution. The next status update will be provided no later than 07:00 UTC.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Jul 02, 2026 - 04:59 UTC

Update

The technical teams have identified an issue affecting the Querétaro, MX (QRO) data center. As a precautionary measure, the PoP will remain bypassed to ensure service stability and is planned to be reactivated during off-peak hours. Customer traffic continues to be served normally through an alternate PoP.

Engineering teams remain engaged in the investigation. The next Status Update on this Incident will be provided no later than 05:00 UTC.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Jul 01, 2026 - 22:52 UTC

Identified

The technical teams have identified an issue affecting the Querétaro, MX (QRO) data center. As a precautionary measure, the PoP will remain bypassed to ensure service stability and is planned to be reactivated during off-peak hours. Customer traffic continues to be served normally through an alternate PoP.

Engineering teams remain engaged in the investigation. The next Status Update on this Incident will be provided no later than 05:00 UTC.

The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Jul 01, 2026 - 21:54 UTC

Investigating

Technical teams are investigating a potential issue in the Querétaro, MX (QRO) data center. The next Status Update on this Incident will be provided no later than 10:11 UTC. Further updates to follow.


The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.

In the event of a service disruption, the update will include potential impacts to any affected region.
Posted Jul 01, 2026 - 21:40 UTC
This incident affected: LATAM PoPs (Queretaro, Mexico (QRO)).