Our teams have confirmed that service performance for Imperva Cloud WAF protected sites has returned to normal and remained stable following mitigation. We will continue to monitor service health as part of our standard operational processes.
Thank you for your patience while we worked to resolve this issue.
Posted Jun 11, 2026 - 08:39 UTC
Monitoring
The issue causing increased latency for Imperva Cloud WAF protected sites has been mitigated.
Service performance has returned to normal, and our teams are continuing to monitor closely to ensure continued stability. We will provide a final update once monitoring is complete.
Please note service impact continued for approximately 15 minutes.
Posted Jun 11, 2026 - 08:15 UTC
Investigating
We are currently investigating increased latency affecting Imperva Cloud WAF protected sites.
At this time, a portion of Imperva Cloud WAF customers may experience slower response times when accessing protected applications through Imperva. Our teams are actively investigating the cause and working to mitigate the impact.
We will provide another update as more information becomes available. The next update will be at 08:36 UTC at the latest.
Posted Jun 11, 2026 - 08:07 UTC
This incident affected: Protection Services (Web Application Performance).