A fix has been implemented and all services are operating normally. The incident has been successfully resolved,
Posted May 22, 2026 - 23:59 UTC
Identified
Investigation has identified a potential contributing factor to the issue. The team is continuing to analyze and validate this finding to better understand its impact on service performance.
Posted May 22, 2026 - 23:53 UTC
Update
Remediation efforts are ongoing and teams are actively working to stabilize the services.
The next update will be communicated at 00:10 UTC.
Posted May 22, 2026 - 23:39 UTC
Investigating
We have discovered a potential issue affecting sites certificates validation. Technical teams are investigating.
The next update will be shared no later then 23:25 UTC.
The status updates are an integral part of proactive monitoring and transparent communication about the status of our cloud services. Imperva investigates and attributes a status to all detected events that may or may not affect availability of the service.
In the event of a service disruption, the update will include potential impacts to any affected region.
Posted May 22, 2026 - 22:56 UTC
This incident affected: Management and Analytics Services (Cloud Security Management Platform).